Survey flow conditions issue
Incident Report for Polyeda
Resolved
This incident has been resolved.
Posted Aug 14, 2023 - 01:08 IDT
Update
We are continuing to investigate this issue.
Posted Aug 13, 2023 - 17:43 IDT
Investigating
We are currently investigating an issue with survey flow conditions that prevent participants from completing surveys
Posted Aug 13, 2023 - 17:43 IDT
This incident affected: Surveys (Survey Forms).